Sub set of customers unable to access MIS

Minor incident Bromcom Cloud MIS - UK
2022-07-02 09:06 BST · 1 day, 2 hours, 54 minutes

Updates

Update

This has has been investigated and resolved by the Cloud team.

July 4, 2022 · 06:17 PM BST
Investigating

Between 20:00 02/07/2022 and 19:30 03/04/2022 a subset of customers were unable to access the MIS.

July 4, 2022 · 06:10 PM BST

← Back