Slowness for subset of customers

Minor incident Bromcom Cloud MIS - UK
2022-04-25 08:56 BST · 1 day, 29 minutes, 20 seconds

Updates

Resolved

Performance improvements were made on the evening of 25/04/2022. Monitoring of the service this morning has shown no further instances of slowness.

April 26, 2022 · 09:26 AM BST
Investigating

From 8:30 this morning a subset of customers will find logging and navigating around the MIS to be slow. This is currently being investigated.

April 25, 2022 · 09:10 AM BST

← Back