Performance

Minor incident Bromcom Cloud MIS - UK
2022-09-20 09:00 BST · 3 hours, 14 minutes

Updates

Resolved

Our team has confirmed that the database servers are now responding normally. They will be undertaking some work this evening to improve the performance for Wednesday 21st.

September 20, 2022 · 12:14 PM BST
Issue

We are seeing slowness on several database servers this morning, starting at 9 am. Our team is currently investigating and working on improving the performance as a priority.

September 20, 2022 · 10:23 AM BST

← Back